CHAPTER 1

Programming in VBA - Using Microsoft Excel 2016

UNDERSTANDING EXCEL VBA

( :INFocus

Visual Basic, or VB for short, is a programming language that was
developed many years ago by Microsoft to help people program their
computers. Microsoft Office has a number of applications that each
have a derivative version of VB which has become known as Visual
Basic for Applications, or VBA for short.

VBA is an object-oriented programming language that performs
operations by manipulating objects, which in turn have methods,
properties and events. Each application in the Microsoft Office
suite, including Microsoft Excel, has its own specific set of objects.

In this session you will:

v/ gain an understanding of programming in Microsoft
Excel

gain an understanding of VBA terminology
learn how to display the Developer tab

gain an understanding of the VBA Editor screen and its
features

learn how to open, close and switch to the VBA Editor
gain an understanding of objects used in VBA

learn how to access the Excel object model

learn how to use the Immediate Window

learn how to work with object collections

learn how to work with property values

learn how to work with worksheets in VBA

learn how to use the Object Browser

learn how to program with the Object Browser

gain an understanding of how to access good and
reliable help for VBA

gain an understanding of the codes used in this chapter.
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PROGRAMMING IN MICROSOFT EXCEL

Microsoft Excel has had some form of tool. It is not overly difficult to learn and use, but it
programming language available to it ever since sometimes can seem complicated until you really
it was first released. Its current programming fully grasp its background and what it is primarily
language, VBA, is a very powerful and versatile designed to do.

The Difference Between Macros And VBA

There is really no difference between macros and VBA. When spreadsheets were introduced to
computing it was possible to program them to perform repetitive procedures. These programs were
simply lists of commands from the standard menu that you wanted to run in a particular sequence.
This early form of a program was known as a macro.

The term macro is still used today — indeed you’ll see it on the Developer tab of the ribbon in
Microsoft Excel 2016. However, these macros are now based on a complete programming language
(VBA) rather than a list of simple commands. So the two terms, macro and VBA, are
interchangeable.

Why Use VBA?

The sole justification behind putting a programming language behind an application like Microsoft
Excel is to extend its capabilities beyond those that you can find on the ribbon. There are several
reasons people decide to program in VBA:

e Repetition — The primary use of VBA is to automate operations (especially those performed in a
repetitive manner). For example, if you need to download accounting data, extract the sales
information and create a chart on a weekly basis, you can write code in VBA to automate these
tasks and ensure they are done quickly and accurately.

e Limitation and Interaction — Imagine developing the world’s best workbook full of facts and
formulas that plots the economies of several dozen developing nations around the world. Then
imagine handing that workbook to one of your colleagues only to find they have accidentally
deleted the area that contained your formulas! With carefully written VBA coding you can guide
inexperienced users through your workbook, giving them access to specific areas and
precluding them from others, providing them with specialised dialog boxes (known in VBA as
forms) and prompting them for key information.

e Cross-application Communication — You can use VBA to write programs that communicate
across applications. For example, using VBA you can pull Word data and charts into a
PowerPoint presentation, or insert sales figures from Excel into a Word document.

Time versus Effort

VBA isn’t always the best way to go about a task. If you only need to perform an operation (even a
complex one) once, then it would be a waste of time to write a program to do it.

Also, there are many actions that can quickly and easily be performed using a command or
commands that already exist on the ribbon. Before you sit down to write a VBA program, check to
make sure that the task can’t already be done in other ways. This is why it is important to have a
good grasp of Microsoft Excel before you attempt VBA.
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VBA TERMINOLOGY

Visual Basic for Applications is a derivative of the application. For example, Microsoft Excel uses
the programming language Visual Basic. Each worksheets while Microsoft Word works with
Office application has its own particular kind of documents. The following notes explain some of
VBA depending on the objects and operation of the key concepts in VBA programming.

Object Oriented and Procedure Driven

Visual Basic for Applications and Visual Basic are both object-oriented programming languages
because they work with objects. Most of these objects appear on the screen, hence the term ‘visual'.

They are also procedure-driven languages using commands and structures from the BASIC
programming language to bind object statements into workable applications.

Objects, Properties, Methods and Events
In VBA an object is anything in an application that you can see and manipulate in some way.

For example, you can manipulate a worksheet by adding rows, deleting columns, displaying gridlines,
and so on. A worksheet is therefore an example of an object. Rows are also objects, as are columns
too. These are child objects of the parent object — the worksheet. This way of organising objects into
a hierarchy is known as an object model.

Objects can be manipulated in one of three ways. You can:
e change the way an object looks or behaves by changing its properties
¢ make an object perform a task by using a method that is associated with the object
e run a procedure whenever a particular event happens to an object.

Objects therefore have properties, methods and events.

Let’s look at a simple real-world analogy to get a better idea about objects, properties, methods and
events. Consider a car: it is an object because you can see it and manipulate it. Its:

e properties are its physical characteristics such as its make, model, colour, and so on
¢ methods define what you can do with the car such as reversing, accelerating, turning, stopping,
and so on

e events are the actions that happen to the car that generate an automatic response from the car.
For example, if you remove the keys from the ignition while the car’s headlights are on (event),
most cars will sound a warning alarm or turn off the lights (response).

The Active Object
In VBA, active describes the object item that you're currently working on.
For example, the worksheet cell that you’re editing or formatting in Excel is the active cell. The
workbook that you are currently working on is said to be the active workbook. The object that is
currently active is said to have the focus.
This is an important concept to understand because most of your VBA programming will be performing
an action on a particular object. If you don’t identify that object correctly, you may find that Excel shifts
focus behind the scenes to a different object and your program will fail.
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DISPLAYING THE DEVELOPER TAB

Before you start working with VBA, you will need macros, among others. The Developer tab is not
to ensure that the Developer tab is displayed on displayed by default; you must enable it using the
the ribbon in Excel. This tab allows you to access Excel Options dialog box.

the commands to display the VBA Editor and run

Excel Options ? X
Try This Yourself: Genera & _
EIE Customize the Ribbon.
Fermulas
Before starting this Proofing P . e g
exercise ensure Excel Seve
anguage "W Add or Remove Filters - Main Tabs
has started and a new, Languzg Wt Al Crart Typen, & Bsckground Removal
blank workbook is Advanced gclrclelrst o » E|H.cme
g alculate How Clipboard
dlsplayed . Customize fibbon Center Fort
Quick Access Toolbar Ecndit\cnal Formatting 4 Alignment
opy MNumber
o Click on the File tab to Add-ins Custom Sort. B S
i Trust Center Decrease Font Size B : ‘-m
display the Backstage Decrease Fo ¥ op 2 s
Delete Sheet Columns F age Layou
e Click on Options to Delete Sheet Rows EEdPage Lot

Email

Fill Color |*
Font I- [ Review
Font Color |> L 1 o Vie
i =4
Format Cells

Format Painter

M Formulas -
u 1 Data

display the Excel
Options dialog box

Click on Customise
Ribbon in the left
pane to display the
options for
customising the ribbon Il

Freeze Panes 4
Increase Font Size

Insert Cells...

Insert Function...

Insert Picture

Insert Sheet Columns New Tab New Group Rename...
Insert Sheet Rows

nsert Table Customizations: Reset =

Macros

Merge & Center - Impert/Export ¥ |

o REEm R > G E Sl

3,
2

i
€

n

In the right pane, click
on Developer so it y N -
appears ticked

Click on [OK] to save 9
the settings and return
to Excel

fi

Cancel

The Developer tab is
now displayed on the

ribbon...
Home  Inset  Pagelayout  Formulas  Data  Review  View I Developer l ACROBAT  Q Tell me what you |
o Click on the =, & Recoram = I Proper P—
ecord Macro =] | pm roperties E Map Properties R Import
Developer tab to see = 3 4 & =

) Use Relative References & View Code ) Expansion Packs Export
Visual Macros Add-  Excel COM Insert Design Source
the available Basic 4 Macro Security ins  Add-ins Add-ins -+ Mode (4] RunDialog Refresh Data
Code Add-ins Controls XML
commands

For Your Reference... Handy to Know...
To display the Developer tab on the ribbon: e Once the Developer tab is displayed, it will
1. Click on the File tab remain on the ribbon until you choose to
. . remove it again. You can do this by
2 CI!Ck on Optlons. ] displaying the Customise Ribbon screen of
3. Click on Customise Ribbon the Excel Options dialog box and clicking on
4. Click on Developer in the right pane so it Developer so it appears unticked.

appears ticked, then click on [OK]
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THE VBA EDITOR SCREEN

The VBA Editor is a separate application Properties Window, the work area in which you
designed to help you create and edit VBA create VBA code in code modules and build
procedures. The VBA Editor comprises four UserForms, and an area for special panes that
main components: the Project Explorer, the can be displayed.

PrOjeCt Microsoft Visual Basic for Applications - Book — O *

EXplOrer | . gt View Inset Format Debug Run Tools Add-Ins Window Help

toolbar

L

EME-dfaamno¢r» s BFY » @
Project - VBAProject &

= =& B

=&} VBAProject (Book1)

125 Microsoft Excel Objects
H] Sheetl (Sheet1)
48] ThisWorkbook

Properties - Sheetl &
=l

|Sheetl Worksheet
Alphabetic ICabegorized |
(ame) ___ ETRE
DisplayPageBreak False
DisplayRightTolLef False
EnableAutoFilter |False
EnableCalculation True
EnableFormatCon True
EnableCutlining  |False
EnablePivotTable False
EnableSelection |0 - xINoRestricti |
MName Sheet1

Scrollarea
[standardwidtn 5.43 - o
Visible -1 - xlSheetvisib =

|»

o | 2

Project The Project Explorer displays the contents of the current VBA project which,

Explorer in the example above, is called VBAProject. (In general terms, a project is
an Office file and all of its associated VBA items, including its macros and
user forms). Contents of a project can include forms, objects such as
worksheets, and modules.

Using the tools in the Project Explorer’s toolbar you can display the code
window (View Code) so you can write and edit code associated with the
selected item; display the object window (View Object) for the selected item,
an existing workbook or user form; and hide or show the object folders while
still showing the individual items contained within them (Toggle Folders).

Properties The Properties Window lists the properties for the object that is currently
Window selected in the Project Explorer or in the work area (in the case of a form)
and displays its current settings.

Work Area The work area is the larger area to the right of the Project Explorer and
Properties Window. It is in this area where the text editor is used to create
VBA code in a module (a window that is designed to hold programming
code) and where user forms are built. (A UserForm is a window or dialog box
that makes up part of an application’s user interface.)

Pane Area The Pane Area is used to display additional mini-windows or panes that can
assist in the development and debugging of programs. The example above
shows the Immediate pane.
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OPENING AND CLOSING THE EDITOR

The Visual Basic Editor is a separate
application that can be accessed from any
Microsoft Office application. When you are
programming you can keep the Editor open and

switch between the Editor and the workbook as
required. Alternatively, you can close the Editor and
return to the workbook, then re-open the Editor
when you need it.

. a Al = I
Try This Yourself:
A B C D E F G H
. . 1 |
» Before starting this 2 T
T exercise you MUST 3 |Divisions Year1 Year2 Year3
. 4
g openthe f'le, & |North 260 288
& Understanding Excel 6 |South 360 414
VBA_1.xIsm... T |Fast 4 = 29
- B |West 166 179
. 9
0 If the macro security 10
warning appears while 11

opening the file click on
[Enable Content]

Home Insert

Your workbook should
now be open...

‘.j Record Macro

Formulas Data Review View Developer

Properties @

Page Layout

YIS

i [5] Use Relative Ref View Cod
e CI|Ck on the DeVeIOper Visual Macros * eatwe. “EN g Add-  Excel COM Insert Design 01 e _0 ¢ Source
tab. then click on Visual Basic % Macro Security ins  Add-ins Add-ins = Mode (2] RunDialog
BaéiC in the COde group Code Add-ins Controls
to open the VBA Editor e
The Editor will open in its
own WIndOW. .. E Microseft Visual Basic for Applications - Understanding Excel VBA_1 xlsm - m} X
S I FI CI d File Edit ¥iew [nset Format Debug Run  Tools Add-lns  Window Help
elect File > Close an - o oan
e EE- - # o om BB @ | n1, ol -
Return to Microsoft Project - VBAProj
Excel o ol x] 8 Understanding Excel VBA_1dsm - Modulel (Code) ===
z |:Ganeral] ﬂ |:Declarat\ons] j

. . = VBAProject (Understand
The EdltOf Wl“ C|Ose and %@ Mlcro]suf'tExceI Objects
you will return to the

Excel workbook...

Press |at] + Fi1] to

reopen the Editor

I @Thls\“forkbonk
E& Modules
g8 Modulel

. d < >
window Properties - Modulel E
Press |ait] + @]to close Module1 Modie =
the Editor window Aphabetic | categorized |

Module1

-
Sub DivisionalNames ()
'

' DivisionalNames Macro
' Prints the names of the divisions of our company.

Range ("LS5") .5elect
BotiveCell.FormulaRI1C1 =
Range ("AE"™) .S5elect
BotiveCell.FormulaRI1C1 =
Range ("AT7") .S5elect
BcotiveCell.FormulaR1C1 =

"Horth"

nSouth™

"East"

== |

For Your Reference...
To open the VBA Editor:

e On the Developer tab, click on Visual Basic
in the Code group, or

o Press ait]+ ]

To close the VBA Editor:

e Select File > Close and Return to
Microsoft Excel

Handy to Know...

o |ar] + F1] acts as a toggle between the
Editor and the workbook. When you use
+|F1] to swap back to the workbook, it keeps
the Editor open rather than closing it.
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UNDERSTANDING OBJECTS

In VBA, an object is anything in an application maximise a window, set a specific application

that you can manipulate in some way. For option, and so on. Each of these items — workbook,
example, your code may open a workbook, worksheet, cell, range, window and application — is
rename a worksheet, select a cell or range, an object.

Object Collections

As you know, you can have several Excel workbooks open at any time. Each of these workbooks is a
separate object that belongs to a collection. A collection is simply a set of similar objects. For
example, Excel's Workbooks collection is the set of all open Workbook objects. Because collections
are objects themselves, they have their own properties and methods that you can use to manipulate
one or more objects in the collection.

The members of a collection are called elements. You can refer to an individual element by the object’s
name or its index value (the index is the number that Excel lists beside the filename in Switch
Windows in the View tab). For example, you can programmatically close a workbook named Monthly
Sales.xlsx using the following two commands (assuming that Monthly Sales.xIsx is the first workbook
opened in the current Excel session):

Workbooks (“Monthly Sales.xlsx”) .Close Or
Workbooks (1) .Close

Notice how the object (Workbooks) and the method (Close) are delimited by a full stop (.).

If you don’t specify an element — such as (“Monthly Sales.xIsx”) or (1) — VBA assumes you are
working with the entire collection.

Object Properties

Every object has a defining set of characteristics. These characteristics are called the object’s

properties and they control the appearance and position of the object. For example, the ActiveCell

object has a Value property that you can use to get or set the contents of the cell.

When you refer to a property you use the syntax Object.Property. For example:
ActiveCell.Value

Properties appear in a listing with a property icon E&'.

Object Methods
An object’'s method describes what you can do with the object. For example, you can save (method)
the active workbook (object).
When you refer to a method you use the syntax Object.Method. For example:
ActiveWorkbook. Save
Some methods have arguments. In this case you use the syntax Object.Method argument1,
argument2, ...
Workbooks.Open “D:\Sales Data\Monthly Sales.xlsx”
The above statement will open the workbook called Monthly Sales.xIsx. This statement has included
only one of the available arguments — the filename and path. Sometimes arguments are compulsory.

For example, VBA needs to know what file to open, so failing to provide a filename here will crash the
program. Sometimes arguments are optional such as whether to open the file as Read Only.

The names of the valid arguments, plus the constants that can be used with them, are listed in the
Help system for each particular method. Methods appear in a listing with the method icon =&,

Object Events

An event is something that happens to an object. The opening of a workbook in Excel is an example of
an event. Although Excel has an Open method that you can use to open a workbook, this method only
initiates the procedure; the actual process of the file being opened is the event.

For example, you may write a procedure (which is called an event handler) that will display a message
box each time a specific workbook is opened.
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VIEWING THE EXCEL OBJECT MODEL

The object model for Excel is a very extensive Excel 2013 and 2016 you can only view pictorial
hierarchy of objects and collections. In versions representations of the individual objects of the
of Excel prior to 2013 you could find a pictorial model. Nevertheless, this is still a great way of
representation of the entire model; however, in finding the methods and properties of an object.

a Microsoft Visual Basic for Applications - Book1 - O X

Try This Yourself: File Edit View |nset Format Debug FRun Tools Add-lns  Window | Help
2- »on @ WS 98 Ml(msof’t\llsuagasl(forApph(atmnsﬂE\p Fl
. . Project - VBAProject x MSDN on the Web
Before starting this = J About Microsoft Visus! Basic Ny Applications..

exercise ensure that your
computer is connected to
the internet...

EMicrosoft | Deve oper Network Signin  MS|

Downloads +~  Programs +~  Community ~  Documentation

Open a new blank
workbook, then open the

MSDN Library > Office development > Office clients ~

Edltor > .ﬁ;;l'efc"Wa' Excel
e In the Editor, select Help i Office 2013 and Iater
> MICI’OSOft VISl.la| Find how-to content, sample code, SDK and APl dacumentation, VBA references, training,
BaS|C for App I | Catl ons » Access and technical articles for developing solutions and customizing Excel
Help tO Open a neW | ¥ Excel 7 Last medified: May 19, 2016
8 G lEE Applies to: Excel 2013 | Excel 207
browser window | iimshiliabiliii
e CI'Ck on EXCE| VBA EMicrosoft | Developer Ne Signin S|
reference in the left pane Downloads +  Programs +  Community ~  Documentation v
o CIICk on ObJeCt mOdeI In =+= > Office development > Office clients > Excel ~
the left pane to display
the list of objects in the [| - oceven eterence Excel VBA reference
mOdeI ’ Office 2013 and later | Cther Versions »
e Scroll to and click on ,
WOI’kbOOkS ObJeCt |n | »  Graph Visual B rence o Contribute to this content
the Ieft pane I R ;B;C':r::’r:aw nterop Assembly is;‘ﬁg:ﬁgifcs\jazedtgz.ig:hT\I;:nL hanges. See our guidelines for
e SCfO|| down to examlne v Excel XLL SDK This reference contains conceptual overviews, programming tasks, samples, and references
the IlStS Of methods and to help you develop Excel solutions,
properties
o Under Propertles CIICk e =+ > Excel vBA reference » Object model > Workbooks Object
on Count to read about c
the Count property anchoctont athon ygorklt))OOks-COU”t Property
Xce
G Close the browser tab checkout ethod _ o
Office 2013 and later | Cther Versions =
Close Method

Count Property Contribute to this content
Creator Property Use GitHub to suggest and submit changes. See our guidelines for
contributing to VBA documentation.

Item Property
Returns a Long value that represents the number of objects in the collection

Open Method
OpE‘TD;l;DREE Method Syntax -L
For Your Reference... Handy to Know...
To access the Excel object model: e Itis more important to know how to find the
1. Select Help > Microsoft Visual Basic for object model than it is to memorise the entire
Applications Help structure. Understanding how these objects,

methods and properties work together will

2. Click on Excel VBA reference o .
come with time and experience.

3. Click on Object model
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USING THE IMMEDIATE WINDOW

The Editor has an Immediate Window that lets

you type instructions and test expressions. It runs

statements immediately as if they were run from

a procedure. You can also precede variables and

expressions with a question mark to perform what
is operations. For example, ?Workbooks.Count
asks “How many workbooks are open?”.

Try This Yourself:

Before starting this exercise
ensure that a new, blank
workbook is open and that the
VBA Editor is displayed...

Select View > Immediate
Window to display the
Immediate Window as a pane
at the bottom of the Editor

Type Workbooks.Add, then
press [enter| to create a new
workbook

Click on Workbooks.Add, then
press Enter| to create another
workbook

You can see the workbooks that
are open in the Project
Explorer...

Repeat step 3 three more times

Immediate

<

Immediate

Workbooks.Rdd

<

Project - VBAProject .&

=R=1IF] .

=& VBAProject (Book1)
%% VBAProject (Book2)
5% VBAProject (Book3)

-3 Microsoft Excel Objects
Sheet1 (Sheet1)
@ ThisWorkbook

Project - VBAProject

X|

]

-85 VBAProject (Book1)
-85 VBAProject (Book2)
8% VBAProject (Book3)
&% VBAProject (Bookd)
#-82 VBAProject (BookS)
2-&% VBAProject (Book6)
E1-£2§ Microsoft Excel Obje

[ Sheetl (Sheet1)

cts

to build up a collection of open
workbooks

@ ThisWorkbook

Click under the last command,
type Workbooks.Open
"C:\Course Files for Microsoft
Excel 2016 VBA\Test_1.xIsx",
then press Ener] to open the
workbook called Test_1.xIsx

Immediate 2ﬂ

Workbooks.Rdd -
Workbooks.Open "C:\Course Files for Microsoft Excel 2016 VBA\Test_l.xlsx"

|
Jd | >

Repeat step 5 for Test_2.xIsx

Type ?Workbooks.Count, then Immediate x|

press Enter| to display the number
of workbooks that are open

Workbooks.Cpen "C:\Course Files for Microsoft Excel 2016 VBA\Test_1.x1sx" A|
Workbooks.Open "C:\Course Files for Microscft Excel 2016 VBA\Test_2.xlsx"
?Workbooks.Count

Leave the workbooks and the | = =
VBA Editor open for the next | f
exercise

For Your Reference... Handy to Know...

To display the Immediate Window: e Computer programming requires a much
e Click on View, then select Immediate higher degree of accuracy than you may be
Window used to. For example, if you have typed the

file and file path details incorrectly or if the
files are in a different location on your
computer, the programming instructions you
type will result in an error message.

To use the Immediate Window:
1. Type a command in the window

2. Press Enter|
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WORKING WITH OBJECT COLLECTIONS

In VBA some objects belong to collections. The

Workbooks collection is the set of all the
workbook objects currently open in the

application. Each item in a collection is known

as an element and must be referenced as part of
the collection, either by name or by its position in
the collection (known as the index), where 1 is the
first workbook you opened, 2 is the second, etc.

Try This Yourself:

Continue using the previous files
with this exercise...

Ensure the cursor is positioned
on a blank line in the Immediate
Window, type
?Workbooks.ltem(1).Name,
then press |enter] to return the
name of the first workbook you
added

Type
Workbooks.ltem(1).Activate,
then press to make this the
active workbook

Type Workbooks.Iltem
("Test_1.xIsx").Activate, then
press enter] to make this
workbook active

Type ?Workbooks.ltem
("Test_1.xIsx").Saved, then
press fnter] to see whether the file
has been saved — True — or
False if it hasn’t been saved

Type Workbooks.ltem
("Test_1.xIsx").Close, then
press Enter] to close the workbook
— if the file hasn’t been saved
you will be prompted to do so

If prompted, click on [Don’t
Save]

Type Workbooks.Close, then
press Enter| to close all workbooks
— don’t save if prompted

© 0

Leave the Editor open for the
next exercise

Immediate

?Workbooks.Count

8
Workbooks.Item(l) .Name
EBookl

|
Jd |

Immediate

Workbooks.Item(l) .Rctivate
Workbooks.Item("Test_1.x1sx").Activate
Workbooks.Item("Test_1.xlsx") .S5aved
False

Jd |

3

Microsoft Excel *
1 ‘Want to save your changes to ‘Test_1.xlsx'?
.

If you click "Don't Save’, a recent copy of this file will be temporarily available.
Learn more

Cancel

a Project - Mo Open Projects & Whe? all ((j)f IIZD|"Ie.WOI’|(bOO|(S
are closed, Project
Explorer is empty

Al

For Your Reference...

To work with collections use the structures: .
CollectionName.ltem(index or name).Method
CollectionName.ltem(index or name).Property =

value

Handy to Know...

You can find out information about the
currently active workbook by using the object
ActiveWorkbook. For example,
?ActiveWorkbook.Name will display the
name of the active workbook.
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SETTING PROPERTY VALUES

Properties affect the way an object looks or
behaves. The properties for objects can be listed
by typing the name of the object followed by a

full stop. VBA includes a built-in list system

(known as IntelliSense) that will list methods,

properties and values as you type your command.
Property values are set by specifying the object,

the property, an equal sign and the new value.

Try This Yourself:

Before starting this exercise
ensure your cursor is positioned
in the Immediate Window in the
VBA Editor...

Type Workbooks.Add, then
press Enter| to add a workbook
(and make it active)

Type ActiveWorkbook.Close,
then press |enter]

Notice how a list of methods and
properties appears when you
press the full stop or get to the
end of a method or property...

Type Workbooks.Add, then

preSS Enterl

Type ActiveWorkbook.Saved =

IntelliSense will list the possible
values for the Saved property.
Let’s use the logical value False
to force Excel to display a
prompt to save the currently
unsaved workbook when it is
closed...

Type False, then press [enter]

Type ActiveWorkbook.Close,
then press

You will be prompted to save
the workbook...

©0

o Click on [Don’t Save]

Leave the Editor open for the
next exercise

Immediate ﬁ
False A|
Workbooks.Item("Test_1.xlsx").Close
Workbooks.Close
Workbooks.hdd _
ActiveWorkbook.Close -

Jd | close 1 »

% CodeName
e Colors
CommandBars
ConflictResolution
Connections
ConnectionsDisabled v
Immediate ﬁ

Workbooks.Close
Workbooks.Rdd
ActiveWorkbook.Close
Workbooks.Rdd
ActiveWorkbook.Saved =|

w i

4| | EliFalse
e True
Immediate

Workbooks.Rdd
BctiveWorkbook.Close
Workbooks.Rdd
ActiveWorkbook.Saved =False

|

X

e Microsoft Excel

! ‘Want to save your changes to '‘Book®¥'7

Cancel

For Your Reference...
To set a property value use the structure:
Object.Property = Value

Handy to Know...

e It can take some time to get used to working
with properties. Some properties can only be
read, while others can be changed. When
you change a property, you are said to be
setting its value. When you read a property,
you are said to be getting its value.
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WORKING WITH WORKSHEETS

Worksheets is a collection of worksheet
objects. It refers to all of the worksheets in the
active workbook. You can insert, modify and
delete worksheets using properties and methods,

Programming in VBA - Using Microsoft Excel 2016

but you can only manipulate worksheets if you
have a workbook open. The following example
demonstrates some of the techniques that you can
use with the Worksheets collection.

Try This Yourself:

© ©© 0 O

Before starting this exercise
ensure all workbooks are closed
and your cursor is positioned in
the Immediate Window in the VBA
Editor...

Type Worksheets.Add, then
press Enterl

An error message will appear —
there is no workbook open in
which to insert a worksheet...

Click on [OK]

Type the following commands,

pressing |enter] after each:
Workbooks.Add
Worksheets.Add
?Worksheets.Count

The number of worksheets in the
workbook will be returned...

Type ?ActiveSheet.Name, then
press Enter| to display the name of
the active worksheet

Type ActiveSheet.Name =
"Budget Data", then press [enter]
to name the active worksheet

Type Worksheets.ltem(2).Delete,
then press Enter|

A warning will appear notifying
you that you may lose data...

Click on [Delete]

Leave the workbook and the VBA
Editor open for the next exercise

Microsoft Visual Basic for Applications X

l Run-time error "1004":
3

Application-defined or object-defined error

[o]'¢ Help
Immediate &
Workbooks . Add N
Worksheets.Add
?Worksheets.Count
2 =
| =
4 3
Immediate &
?Worksheets.Count A|
2
?hctiveSheet.Name
Sheet2 1
| =
4| | »
Immediate ﬁ
2 -
?hctiveSheet.Name
Sheet2
LeotiveSheet . .Name = "Budget Data™
-
< | »
e Microsoft Excel *
| Microsoft Excel will permanently delete this sheet. Do you want to continue?
Cancel

For Your Reference...

Handy to Know...

To work with Worksheets use the structure:
Worksheets.ltem(/ndex or “Name”).method

Worksheets.ltem(Index or “Name”).property =
value

e Cryptic error messages are common
occurrences in VBA, both for beginners and
for experienced programmers.
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