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CHAPTER 1 RESOURCE LEVELLING 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In a perfect world you will always have enough resources to 
complete the tasks in your project. The problem is that the world 
isn't always perfect and you will not always have enough resources 
for the work you’ve scheduled. This is known as over-allocation. 

Resources become over allocated in a project when they are 
scheduled to do more work than can be accomplished in the 
specified time. Resource levelling resolves any over allocations 
which exist in your project. 

Microsoft Project gives you two options when levelling – letting 
Microsoft Project level the schedule for you or resolving the 
resource over allocations yourself. 

In this session you will: 

 gain an understanding of resource over allocations 

 learn how to create resource chaos in a project 

 learn how to track down resource over allocations using 
the Resource Graph 

 learn how to check Resource Usage for over allocations 

 learn how to create an over allocated resources report 

 learn how to change work effort to fix over allocations 

 gain an understanding of assigning overtime to resources 

 learn how to assign overtime to fix over allocations 

 learn how to assign contract labour to fix over allocations 

 learn how to switch work assignments to fix over 
allocations 

 learn how to reschedule tasks to fix over allocations. 

INFOCUS 
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UNDERSTANDING RESOURCE LEVELLING 
 

 

 

 

Levelling refers to the even allocation of 
resources. When you assign more resources to a 
task than you have available the resource is said 
to be over-allocated and requires levelling. 

Sometimes over-allocation is also referred to as a 
resource conflict – you simply have too much 
work for a resource to do. 

Resolving Resource Conflict Using Levelling 

Resource conflicts occur normally when you are entering the resources against the tasks. You may not 
have noticed that the same resource is required in more than one place. However, because Microsoft 
Project is constantly recalculating the start and finish dates it is able to provide you with accurate 
details about these overlaps, or over-allocations, in work commitments. 

The process of resolving these over-allocations is called levelling (although Project spells it as 
Leveling). This term stems from the fact that in a perfect project all of your resources will be spread 
evenly, or flatly, across the scope of tasks. An over-allocation suggests that you have a bump or peak 
usage that needs to be ironed out. 

Project has a special Resource Graph view as shown below which demonstrates this concept of over-
allocation and levelling. 

In the graph the 
thicker line at 500% 
indicates that this is 
the maximum units 
that we have in the 
resource pool. Any 
bar above this line 
indicates an over-
allocation of 
resources. This 
peaking needs to be 
eliminated. 

Microsoft Project 
provides you with 
the ability to 
automatically or 
manually level over-
allocations. 

If you choose automatic levelling Microsoft Project will attempt to resolve the conflict for you. Usually 
this is done by slipping the task dates out. It does this by adding delay to the tasks so that resources 
are not required at the same time. However, with automatic levelling you do forfeit control over your 
project. Most people prefer to resolve over-allocations manually. 

This can be done by: 

 moving a task that has an over-allocated resource within the project so that the task dates 
are changed to a date when the resource is free 

 increasing the maximum units of the resource (usually by hiring or seconding additional 
staff) 

 assigning a different resource that is currently free to the task 

 assigning overtime 

 extending working days on the calendar used by the resource so that more time is available 
to work on the tasks. 

Obviously not all of these options are practical. For example, if you have a deadline to meet, slipping 
the task dates by moving the task further down the timeframe is not good. In this circumstance you 
may be better off hiring more staff or allocating another resource to the task. 

Similarly, if your project is constrained by costs then you may need to slip the dates out rather than hire 
or buy additional resources or allocate overtime to the task. 
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 CREATING RESOURCE CHAOS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Before starting this 
exercise you MUST open 
the file J408 
Levelling_1.mpp... 


Click on the Project tab 
on the Ribbon and click 
on Project Information in 
the Properties group 

The case study project is 
currently scheduled to 
finish on Wednesday April 
27… 


Click on [OK] to close the 
dialog box 


Click on the View tab on 
the Ribbon and click on 
Resource Sheet in the 
Resource Views group 


Click on 200% in Max for 
Draftsperson, type 100% 

and press  


Hover over the warning 
icon and read the (less 
then helpful) message 
that appears 


Repeat step 4 and 
change the number of 
resource units for the 
resources: Rigger 500%, 
Carpenter 600%, Driver 
200% 

 

For Your Reference… 

To create resource chaos: 

1. Reduce the number of units of a resource(!) 

Handy to Know… 

 Over-allocations also occur when more 
resources are assigned to a task than there 
are units in the resource pool. For example, 
Microsoft Project will allow you to assign 10 
carpenters to a task even though only 5 exist 
in the resource pool. 

 

6 

Our case study project is totally sanitised – we 
have ample resources to complete the required 
tasks. However, the project manager has just 
been advised that a second project is to begin 

elsewhere and some of the resources he has in the 
resource pool will be taken away to work on the 
new project. Having carefully assigned resources to 
the various tasks this will now wreak chaos. 

4 This action has effectively halved the drafting resources in 
your project. Since there were more resources available 
when you did the initial assignments there are now times 
when the resource is over committed. Our committed 
(allocated) resources appear in red. A warning icon appears 
in the left column. 
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TRACKING DOWN OVER ALLOCATIONS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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 Continue using the previous 

file with this exercise, or open 
the file J408 Levelling_2.mpp... 


Click on the View tab on the 
Ribbon, click on Other Views 
in the Resource Views group 
and click on Resource Graph 


Press  +  , then  

+   


Press  until the 

Draftsperson comes into view 

This resource is over allocated 
as indicated by the colouring of 
the name and in the chart… 


Press  until you can see 

the Rigger and press  + 

 to return to the start of the 

project 


Click on the Resource tab on 
the Ribbon and click on Next 
Overallocation in the Level 
group to see the over 
allocation for the Riggers 


Click on Next Overallocation 
again and you will be advised 
that there are no more over-
allocations for this resource 


Click on [OK] 


Repeat steps 4 to 7 with the 
Carpenter resource 

 

For Your Reference… 

To display over allocations as a chart: 

1. Click on the View tab, click on Other Views 
in the Resource Views group and click on 
Resource Graph 

2. Click on the over allocated resource 

3.  Click on the Resource tab and click on the 
Next Overallocation command 

Handy to Know… 

 In earlier versions of Microsoft Project a 
message would appear on the status bar at 
the bottom of the screen to indicate that 
resources needed to be levelled. This no 
longer appears in Project. 
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Over allocations aren't immediately apparent – 
unless they arise when you are changing data in 
the resource sheet as we have done. Over-
allocations can be quite insidious and it is a good 

idea to check the resource pool on a regular basis 
to see whether there are over-allocations in your 
project. Remember, over-allocated resources 
appear bolded red in the resource pool. 

3 
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CHECKING RESOURCE USAGE 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J408 Levelling_2.mpp... 


Click on the View tab on 
the Ribbon and click on 
Resource Usage in 
Resource Views 


Press  +  to 

move to the top of the 
resource list 


Scroll to and click on 
Draftsperson, click on 
the Task tab on the 
Ribbon and click on 
Scroll to Task  in the 
Editing group 


Scroll to and click on 
Rigger and click on 
Scroll to Task in the 
Editing group 

 

For Your Reference… 

To check resource usage for over allocations: 

1. Click on the View tab on the Ribbon and 
click on Resource Usage in Resource 
Views 

2. Scroll to over allocated resources 

Handy to Know… 

 We didn’t use the Next Overallocation 
command to move to the task in the timeline 
in the Resource Usage view because at the 
time of writing there was an erratic and 
inconsistent bug in this command – but only 
when used in Resource Usage view. 

 

1 

4 

Another great way of tracking over allocations, 
and more importantly the extent of over 
allocation, is through the Resource Usage view. 
This view presents a sheet at the left which is 

organised in order of resources and the tasks that 
they are working on. At the right is a timeline view 
which shows the hours the resource works. Over 
allocated resources appear in red colouring. 
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CREATING AN OVER ALLOCATION REPORT 
 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J408 Levelling_2.mpp... 


Click on the Project tab 
on the Ribbon and click 
on Reports to display 
the Reports dialog box 


Click on Assignments 
and click on [Select] to 
see the Assignment 
Reports dialog box 


Click on Overallocated 
Resources and click on 
[Select] to see the 
Overallocated 
Resources report in 
preview mode 


Adjust the print settings 
as required and click on 
[Print] to print the report 


Click on the Task tab on 
the Ribbon to return to 
the normal view of the 
project 

 

For Your Reference… 

To create an overallocated reources report: 

1. Click on the Project tab and click on 
Reports 

2. Click on Assignments and click on [Select] 

3. Click on Overallocated Resources and click 

on [Select] 

Handy to Know… 

 It is a good idea to print this report before 
you commence levelling operations so that 
you know the road and the task ahead of 
you. 

 

1 

2 

Microsoft Project contains a number of in-built 
and pre-defined reports which help you locate all 
sorts of information about, and problems in, your 
project. One such report, the Overallocated 

Resources report, lists all of the resources that are 
over allocated in your project and which tasks 
contain those over allocations. This is a handy 
report to use when levelling your project. 
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FIX 1: CHANGING WORK EFFORT 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J408 Levelling_2.mpp... 


Click on the View tab on 
the Ribbon and click on 
Resource Usage 


Scroll to and click on 
Draftsperson, click on 
the Task tab on the 
Ribbon and click on 
Scroll to Task 


Click on Gantt Chart to 
see a Gantt Chart view 


Right click on the icon 
next to Create 
architectural plans and 
click on Fix in Task 
Inspector 


Click on [Reduce Work] 
to remove the over 
allocation 


Click on Create 
architectural plans and 
click on Details to see a 
task form in the lower 
pane of the screen 

Notice that the hours for 
the draftsperson show 
112.5h (3w x 37.5h)… 


Click on the close button 
of the Task Inspector 

 

For Your Reference… 

To change the work effort: 

1. Right click on the icon next to the task with 
the over allocation and click on Fix in Task 
Inspector 

2. Click on [Reduce Work] to remove the over 
allocation 

Handy to Know… 

 You could have done this manually yourself 
by typing the 112.5h hours in the Work field 
for Draftsperson. But, hey, why not use the 
Task Inspector to do the leg work! 

 

1 

6 

There is no right or wrong way to level over 
allocations – the methods that you choose are 
determined by the nature of your project. The 
best way to tackle over allocations is one at a 

time. We'll start with the Draftsperson. We 
identified a work requirement for two draftspersons 
to create the architectural plans. It has been 
decided that there is only enough work for one. 

4 The problem here is that the task Create architectural plans 
requires/shows 15 hours of draftsperson work on most days – since 
a day is 7.5 hours this means that there is a requirement for 2 
draftspeople. 
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UNDERSTANDING OVERTIME 
 

 

 

 

  

You can reduce the overall duration of a resource 
assignment in a task by assigning overtime to 
the resource. The total work for the assigned 
resources remains the same, but the task 

duration is reduced. In Microsoft Project overtime is 
defined as the work scheduled to take place 
beyond the regular working hours of the resource. 

The Effect of Overtime On Task Duration 

We have an over-allocation with the riggers. As you'll soon see this is only in one task – erecting the 
steelwork. In our case study there is a specific amount of work to be done on this. The riggers 
prepare and assemble some of the steelwork units that are then lifted into place. 

We are actually short one rigger. Scott Harris has decided to overcome this shortfall by assigning 
overtime to the other riggers – they'll work enough overtime to cover the shortfall of one rigger. 

In Microsoft Project assigning overtime can shorten the duration of a task. A task requires a specific 
amount of work effort by the resources to complete the task within the required duration. The duration 
of the task is calculated on the basis that the work effort will be done in regular work time. 

However, if some of that work effort is done in overtime (that is, outside of regular work time) then 
the duration of the task will shorten – providing effort from other resources doesn’t come into play. 
Consider the table below: 

Total Work Ovt Hours Reg Work Time Duration 

15h 0h 15h 2 days 

15h 3.75h 11.25h 1.5 days 

So how does this help us? Well, our task is effort driven. At the moment it requires 6 riggers per day 
to complete. 

Take one rigger away and the duration will be longer – assuming that the same amount of work 
needs to be done by the five remaining riggers. 

However, by assigning overtime we should be able to pull the duration back to its original amount. 
This is presented numerically in the form below. 
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FIX 2: ASSIGNING OVERTIME 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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e
 Continue using the 

previous file with this 
exercise, or open the 
file J408 
Levelling_3.mpp... 


Ensure you have a 
split screen view, click 
in the top pane, click 
on the View tab on the 
Ribbon and click on 
Resource Usage in 
Resource Views 


Scroll down, click on 
Rigger, click on the 
Task tab on the 
Ribbon and click on 
Scroll to Task 


Click in the lower 
pane, click on the 
Format tab on the 
Ribbon and click on 
Work in the Details 
group 


Click on 600% in Units 
for Riggers, type 500 
and click on [OK] 


Click on 0h in Ovt. 
Work for Riggers, 
type 450h and click on 
[OK] 

Fixed! The task is back 
to 3 months and the 
Rigger is no longer 
over allocated 

 

For Your Reference… 

To assign overtime to a resource: 

1. Ensure a Task Form appears with the Work 
format 

2. Type the appropriate overtime in the Ovt. 

Work field and click on [OK] 

Handy to Know… 

 Microsoft Project subtracts overtime from 
total Work (2,700 – 450 = 2,250), then 
divides this by the number of riggers (2,250 / 
5 = 450). This in turn is then divided by the 
number of hours per week (450 / 150 = 3) to 
determine how many weeks of work are 
required by this resource. 

 

4 

To resolve a resource over allocation, you may 
need to assign overtime. By definition, overtime 
is something that happens outside of the normal 
working hours. The value in Work represents 

total hours for a resource. Any value in overtime is 
subtracted from the total Work and this in turn may 
impact on the task duration. Generally, more 
overtime results in a shorter task duration. 

5 

The duration has pushed out to 3.6 months because the Work for the 
Riggers (2,700h) is now divided by 5 riggers to derive total work of 540 
hours for each rigger. Since there are 150 hours of work per week (37.5 
x 5) when you divide the total hours (540h) for a rigger by 150 you get 
3.6 months. 
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FIX 3: HIRING CONTRACT LABOUR 
 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J408 Levelling_4.mpp... 


Scroll the top pane until 
the Carpenter resource 
can be seen, click on 
Erect wall, click on the 
Task tab on the Ribbon 
and click on Scroll to 
Task 


Click in Resource 
Name below Plumber, 
type On The Hammer 
and click on [OK] 

Now we can adjust the 
carpenters down… 


Click on 700% in Units 
for Carpenter, and type 
600%, then click on 
2,100h in Work, type 
1800 and click on [OK] 


Double click on On The 
Hammer to display the 
Resource Information 
dialog box 


Change the Units to 
1000%, type OTH in 
Initials, and type 
Contract Labour in 
Group 


Click on [OK] 

 

For Your Reference… 

To add a new resource to cover over allocations: 

1. Click in Resource Name, type the name of 
the resource and click on [OK] 

2. Enter the appropriate Work for this new 
resource, then deduct the same amount from 
the over allocated resource 

Handy to Know… 

 In our case study Scott Harris has access to 
an endless supply of contract carpenters – 
that is why we entered a large sum of 1000% 
units. 

 

5 

Scott Harris doesn't have enough carpenters to 
complete some of the work that needs to be 
done. In times of dire emergency he does have 
permission to bring in additional contract 

tradespeople. We will have to add a new resource 
to the pool, then assign the resource to the task, 
being careful that we don't accidentally change the 
duration due to the effort-driven nature of the task. 

3 
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FIX 4: SWITCHING WORK ASSIGNMENTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J408 Levelling_5.mpp... 


Click on Erect seating 
tiers in the upper pane, 
click on the Task tab on 
the Ribbon, and click on 
Scroll to Task 


Type 600% in Units for 
Carpenter and type 
675h in Work 

This represents 3 weeks 
work for 6 carpenters (6 
x 3 x 37.5 = 675)... 


Type 700% in Units for 
Labourer and type 
787.5h in Work  

This represents 3 weeks 
work for 7 labourers (7 x 
3 x 37.5 = 787.5)... 


Click on [OK] to record 
the revised assignments 

The carpenter resource 
should no longer appear 
over allocated 

 

For Your Reference… 

To switch work assignments: 

1. Select the task 

2. Adjust the units and/or work effort for the 
over allocated resource 

3. Click on [OK]  

Handy to Know… 

 Switching assignments in Microsoft Project is 
relatively easy to do providing you take into 
consideration the effort-driven nature of your 
tasks. 

 

2 

The task of erecting the seating tiers requires 8 
carpenters, but there are only six in the pool. 
Scott could use the contact labour – but these folks are 
pricey. So, industrial relations issues aside, he has 

decided to give some of the more menial carpentry tasks 
to the labourers. 
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FIX 5: RESCHEDULING TASKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 
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Continue using the 
previous file with this 
exercise, or open the file 
J408 Levelling_6.mpp... 


Scroll down in the top pane 
and click on the Driver 
resource, click on the Task 
tab on the Ribbon and click 
on Scroll to Task 


Use the scroll bar below the 
timeline until red values 
appear in the Driver row 


Click on Erect wall in the 
upper pane, then click on 
the active pane bar in the 
Task Form (lower pane) 


Click on the Format tab on 
the Ribbon and click on  
the Predecessor and 
Successors command 


Click on -10% in Lag, type 
0 and click on [OK] to 
remove the over allocation 


Click on the Project tab on 
the Ribbon and click on 
Project Information 

The finish date is now 
Thursday May 5… 


Click on [OK] 


Double click on the divider 
line between the panes, 
click on the Task tab and 
click on Gantt Chart 

 

For Your Reference… 

To reschedule an over allocated task: 

1. Display the predecessors in a task form 

2. Adjust for lag or predecessor relationships 

Handy to Know… 

 When you want to switch to another view 
from a combination view, remember to 
remove the split in the window. For example, 
double click on the line between the two 
panes, then select Resource Sheet view to 
check that all over allocations have gone. 
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We have an over-allocation of drivers. This over-
allocation has arisen because the resource is 
required on two different tasks at the same time. 
Scott doesn't want to use additional resources, 

and overtime isn't practical as the work of the driver 
is required in normal working time. Scott has to 
reschedule the tasks – but can this be done and 
still meet the project deadlines and timeframes? 
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