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Microsoft Access 2010 is described as a database management
system (DBMS).

A database is a structure that contains data. You enter data into the
database via a variety of sources including typing (data entry),
importing from other sources, and even electronically and
automatically from other equipment (data logging). The data can
then be manipulated by the DBMS to provide a range of useful
information.

In this session you will:

v/ gain an understanding of how Access works and what it
can be used for

learn how to start Microsoft Access 2010

gain an understanding of the Backstage View
learn how to open an existing database file

gain an understanding of the Access 2010 screen

learn how to work with the Navigation pane to list
database objects

learn how to work with a table

learn how to work with other database objects
learn how to close a database file

learn how to exit from Access 2070.
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UNDERSTANDING MICROSOFT ACCESS 2010

Microsoft Access 2010 has a reputation for being a good orientation to Microsoft Access will greatly
a more difficult application to learn and use than help in understanding how this powerful application
its Office 2010 siblings: Word, Excel, and can be used to perform a range of useful jobs for
PowerPoint. There are many reasons for this and work and even for pleasure.

o How Access is Different

Unlike it's Office 2010 siblings, Word, Excel, and PowerPoint where you can start to create
something useful almost immediately and directly on the screen, Access 2010 needs you to first
design and create structures to hold your data, and then create special template layouts for
displaying, manipulating and presenting that data in a useful and meaningful way. In other words,
rather than just play around and look and see how things are going, Access requires more
thought, more planning, and good designs in order to be used effectively. While there is a lot of
learn by doing involved with Access, there is also great deal more learn before doing associated
with it.

e How Access Works

Basically, Access allows you to do two main things: firstly, it allows you to sfore huge amounts of
data, and secondly, it allows you to manipulate that data to produce relevant and useful
information. This is what Database Management Systems (DBMS) are all about, and the good
news is that Access is one of the easiest of these to learn and use.

Data is stored in tables. Tables are structures made up of rows and columns and are similar in
appearance and operation to Excel worksheets. You do however need to design and create these
tables yourself, before the data can be entered.

The data in tables is manipulated using forms, reports, and queries. A form is mostly used for
data entry (although you can enter data directly into a table). A report is used to manipulate the
data and present it either on the screen or printed on paper in a more pleasing way. A query is
used to produce a sub-set of the data — for example, in a sales system you may only want to see
the sales in the northwest region.

Forms, reports, and queries are created as layout frameworks. Once the framework has been
designed you can then run the data from the tables through them. Indeed, this is a common
theme throughout Microsoft Access: design versus display. You create or modify a form, or
report, or query in design mode, and then preview the data in display mode.

Even tables (that store your data) conform to this design/display metaphor. You design a table
structure, then enter the data in a display (they call it a datasheet) view.

Tables, forms, reports, and queries are known as database objects. In fact each of these is like
a mini-application within the broader Access application. Each has a very large range of
commands and options that you can use to both design the structure or framework and also use
to display data.

e What can Access be Used for?
Virtually anything — no exaggeration!

You can use Access to create a system for managing your music or stamp collection, the
membership at your local soccer or polo club, the petty cash, inventory and stock control, or sales
at work, and much, much, much more. Any situation where you need to store data, manipulate it,
and then present it as useful information is a perfect contender for Access.

The only snag with Access is that unless you use one of the pre-created system templates, you
need to plan and design the system and the database objects (the tables, forms, reports, and
queries) used in that system. And this is what takes time and learning to do.
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STARTING ACCESS

To create a new database, or work with an started is determined by Windows. For example, it
existing one, the first thing that you need to do is can be started from the Windows Start menu, from
to start Microsoft Access. As a standard a shortcut, or even by opening a database that
software application, how Microsoft Access is was created previously in Access.
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For Your Reference... Handy to Know...
To start Microsoft Access: You can also start Access by:
e Double-clicking on an Access shortcut

2. Click on All Programs, click on Microsoft e Double-clicking on a database file icon in a

Office, then click on Microsoft Office file I|st|.ng
Access 2010 e Choosing a database from the Recent Iltems

list on the Start menu

1. Click on the Start button e
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UNDERSTANDING THE BACKSTAGE VIEW

Before you are allowed to properly enter etc) for a particular system or project you are
Microsoft Access 2010, you must have a working on are located. The Backstage View is,
database file open. A database file is where your amongst other things, a gateway to Access where
database objects (tables, forms, reports, queries you can nominate which database to open.
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Cﬂ Save :
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o When you open Microsoft Access 2010 or click on the File tab, Backstage View is displayed. By
default, the New tab is selected. This tab offers a number of ways for you to create a new
database. To open an existing database, you need to click on Open, which will display a traditional
Open dialog box.

e The Recent tab displays databases that have been recently opened. This is a particularly useful
feature if you find that you are regularly using the same database and coming back to it on a
frequent basis. This list can display up to the last 50 opened databases. All you need to do is to
click on the desired database and it will be opened for you.

You will also see the last 4 opened databases listed directly in the File tab, for quick access.

e The Available Templates icons provide you with a range of pre-designed database templates that
come with Access and also enable you to use online templates from Office.com. The templates
generally already have database objects such as tables, forms, reports, and queries designed and
created for you. All you need to do is to enter the data into the tables.

While templates sound like a good idea, they can actually cause you more work and trouble. It is
unlikely that a template will exactly meet your needs, so some modification will be necessary to
adapt it to your requirements. It can sometimes be quite time-consuming learning how the template
is structured and then making the required changes.

o Click on the Blank Database icon in Available Templates to create a new, blank database. You
need to specify a File Name for the new database and select location for where it will be stored by
clicking on the Browse icon |5.

e The Preview offers a large thumbnail of the selected database.
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OPENING AN EXISTING DATABASE FILE

A good way to see how Access 2010 works is to Backstage View. However, if it doesn’t appear
open an existing database file. If the database here you will need to use the Open option to
file has recently been opened it will appear in the display the Open dialog box, to search for and
Recent Database listing in the left panel of the open the database file.
(2 =
Tl"y ThiS Yourself: o v|n!J| 3 | Computer » - |"f| ‘ Search P |
ganize ¥ oo
Before starting this exercise L
ensure that the Backstage Favorite Links Name . . Type Total Size Free Space
View is displayed... 18 Computer Hord Disk Brives 2 )
% Recent Places ~ Hanl DEK(C)
o Select Qpen in Backstage E Desktop p 61.1 GB free of 136 GB
View to display the Open Pictures . RECOVERV(D)
dialog box Py P B Music S 634 G fres o755 5
E Searches X X
] Devices with Removable Storage (1) ~
Let’s change the folder & Public
location to display our $ DVD RW Drive (E)
existing database files...
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pane of the dialog box - W il ey ———
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click on the icon for C drive e (8] Open L=
(Hard Disk C_')’ then %v| 11+ Course Files for Access 2010 - |‘1‘| ‘ Search P|
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[Open] to open the (5] A805 Modifying Tables_2.accdb (] AB11 Trans
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atabase b b
J Public (21} A805 Modifying Tables_5.accdb (25 A811 Trans
' (1) A805 Modifying Tables_6.accdb (1) Ag11 Trans
(1) A805 Modifying Tables_7.accdb (1) Ag11 Trans
(21 A805 Modifying Tables_8.accdb (1) Ag11 Trans
(1) A805 Modifying Tables_9.accdb (2 4813 Data
(2} 4810 Adding Records_1.accdb (2] 4813 Data
(2} 4810 Adding Records._2.accdb (2} 4813 Data
Folders Ay |I| »
File name: - [Mcnstﬂm(‘.am{:.‘n V]
Tools v | Open |¥ [ Cancel ] .
For Your Reference... Handy to Know...
To open an existing database file: e You can also use the keyboard shortcut
1. Select Open in Backstage View + 0 ] at any time to display the Open

. Move to the folder that contains the file dialog box.

2
3. Click on the file to select it
4. Click on [Open]
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UNDERSTANDING THE ACCESS 2010 SCREEN

At first glance there’s nothing much to an Access (tables, forms, reports, queries, etc). It isn’t until
2010 database screen. The screen really only you choose to perform one of these operations that
gives you access to either create, modify, or run the screen really becomes more intricate.

one of the database objects in a database file

-
@ds-wo-|= Microsoft Access lilglg
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4 E= Al pcrending Tz = New 3. a = - 3= §=
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— =F. il[;e:-:en-:ling {j =H Save ? = B I U | (=< 3] EH
View Paste Filter Refresh Find Size to Switch F JEE——
7 f}‘_/ Remove Sort W All ¥ Delete ~ B kg Fit Form Windows~ | A = %7 - & === @
Views | Clipboard Sort & Filter Records Find Window Text Formatting
Tables ® «
T Assetltems
—_— Ready Mum Lock

The Ribbon is the tabbed band that appears across the top of the window. It is the command control
centre of Access 2010. You use the tabs on the Ribbon to access commands which have been
categorised into groups. Commands can be buttons or sometimes include galleries of formatting options
that you can select from. This area really comes to life when a database object is opened.

The File tab of the Ribbon is used to access file management functions such as saving, opening,
closing, printing, etc. Access Options are also available so that you can set your working preferences and
options for Access 2010.

The Navigation Pane is used to list and navigate the various database objects (tables, forms,
reports, queries, etc) that exist in the database. In the screen above this area has been filtered
so that only table objects appear — there is only one table in this database and it is named Asset
Items.

The main part of the screen is the data area. Here a database object will appear either in
design or in preview mode. The database object must first be opened before it will appear so,
even though Asset Items in the screen above is selected, it hasn’t yet been opened.

The Security and Message area displays information about the database object that is
currently open. Since there are no objects open the area isn’t really showing much at the
moment other than the fact that it is ready for you to start something.
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WORKING WITH THE NAVIGATION PANE

The Navigation Pane is an essential part of

Access 2010 as it provides you with access to
the database objects that are in your database
file. The pane itself can be filtered to show you

more or less objects and you should get a pretty
good grasp on how it operates before commencing
to create tables or other database objects.

. o All Access Objects ( 'L\“}« e Queries ® «
Try This Yourself: Navigate To Categoy— |
Custom [ qryCostsSummedByOwner

Continue using the previous
file with this exercise, or
open the file A Sample
Database.accdb...

» | Object Type qryG5TCaleulations

Tables and Related Views

Same
File

Created Date
Maodified Date

Click on the drop arrow @ Filter By Group

for All Access Objects in Tebles

the Navigation pane to Queries |

display the menu Forms l
Reports

Click on Queries under | Al Access Objects

Az by Group to see all rptGSTPaidByMonth

of the saved query objects
in the database

Click on the drop arrow i=}
again and click on Reports
to see a list of all of the

© 6 6 o0 o o

reports
Click on the drop arrow i} - -
again and click on All e All Access Objects ® « e All Access Objects ® «
- Tables 3 Tables 3
Access Objects to see all =
! Asset Items EH Assettems
of the database objects — r — r

Click on the up arrow |z | for
Forms in the Navigation
Pane to hide all of the
forms

Click on the down arrow
that have appeared to
display the forms again

qryComputerHardwareInChwn...
qryCosts5ummedByOwner

qryGSTCalculations

Forms (

n
_/

Reports
rptAssetlistingInMumberCrder
rptAssetsGroupedByOwners

rptGSTPaidByMonth

qryComputerHardwareInChwn...
qryCosts5ummedByOwner

qryGSTCalculations

frmAssetinventory
frmAssetltemsDataForm
frmG5TCalculations

Reports 3
rptAssetlistingInNumberCrder

rptAssetsGroupedByOwners

rptGSTPaidByMonth

For Your Reference...
To filter database objects:

1. Click on the drop arrow = for the object type

in the Navigation pane
2. Click on the desired filter option

Handy to Know...

o The Navigation pane menu is more complex

than we’ve used here. Once you've become

proficient with it you can list the objects by
date created or modified. However, the best
option is to list objects grouped according to

their type.
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WORKING WITH A TABLE

A table is used in a database file to store data. A in Design mode you can make changes to the
table has a defined structure and in Access 2010 structure of the table but not the data itself, and
whenever the table is open, it is seen either in when it is in Datasheet mode you can make
Design mode or in Datasheet mode. When it is changes to the data but not the structure.
= Asset items
. . o AssetNo - AssetCategory  + Make - Model .| Descripion - Oy
Try ThIS Yourself- | EiOER Computer Hardware GEO Rocket 220ZX Computer Sales
30051 Computer Hardware GED Blast Surger 350 Computer Sales
. . 30052 Office Furniture FurnTown GasRiser Computer Chair Sales | _
o Continue using the 30053 Office Furniture FurnTown WideSpan Credenza Sales  |=
= . . . . 30054 Computer Hardware GED Blast Surger 350 XL | Computer Admin &
'-L preV’Ous flle Wlth thls 30055 Computer Hardware GEQ Blast Laptop WZ Computer Laptop Admin &
Q exercise or Open the 30056 Office Furniture FurnTown GasRiser Computer Chair Sales
S ) ’ 30057 Office Furniture FurnTown WideSpan 6 | Desk Sales
(fg fl/e A Samp/e 30058 Office Furniture Granville Combo Unit Executive Cupboard | Sales
30059 Computer Software MicroSwift Office Master | Software Maintena
Database.accdb... 30061 General Equipment Brenda Pro Master Stapler Maintena
30062 Office Furniture FurnTown WideSpan 6 Desk Maintena
. 30066 Computer Hardware GED Rocket 2207 Computer Sales
o Double-click on Asset 30067 Computer Hardware GED Rocket 220z Computer Sales
Items under Tables in 30068 Office Furniture FurnTown GasRiser Chair Productic
. : 30069 Office Furniture FurnTown WideSpan6 | Desk Productic
the NaVlgatlon pane, to 30070 Office Furniture Granville Combo Unit Executive Cupboard | Productic
. 30071 General Equipment Sandly GF780 Photocopier Sales
open the table in 30072 General Equipment Sandly GFE50 Photocopier Maintena
— thi 30073 Computer Hardware Dennis H445 Laser Printer Maintena
DafjaSheetgnOde th|S 30074 Computer Hardware Dennis H445 Laser Printer Sales
maode provigaes access 30075 Computer Hardware Dennis H445 Laser Printer Productic
P 30076 Computer Hardware Dennis H445 Laser Printer Admin &
to the actual data 30077 Ceneral Equipment GFE HO90C Fax Machine Adrmin & [+
Record: 4 4 10f65 | b M b | & No Filter | Search 4] [ | [»]

e On the Home tab of the
Ribbon, click on the top

half of View % in the e o pr—

Views group, to switch Field Name Data Type Terwn H
2] R s Text Records the asset number =
to Des’gn view Category Text Records the asset type
g a Make Text Records the item make
Thls mOde dlSPIayS the Model Text Records the item model
structure Of the table Description Text Records a brief description of the item
: Owner Text Records the owner of the asset
g Serial No Text Records the serial number of the asset
There are aISO view Acquired Date/Time Records the date that the asset was purchased El
buttons at the bottom of
the screen which allow [ General [rogkup]
you to toggle between el Size : 2
design and datasheet Input Mask
modes_ .. Default Value
Validation Rule A field name can be up to 64 characters long,
0 Walidation Text including spaces. Press FL for help on field
@ (Clickor Datasigg s e I |
view in the bottom Indexed Yes [No Duplicates)
. . Unicode Compression Yes
rlght of the window to MEMae No Control
see the data again S s Mode__Hone .
o Click on Close E to
close the table
For Your Reference... Handy to Know...
To display a table: e Clicking on View ¥ in the Views group (on
1. Double-click on the table name in the the Home tab of the Ribbon) toggles
Navigation pane to display the table in between Design and Datasheet views. For
datasheet view example, if you are in Datasheet view,
: . ] . . clicking on it will switch to Design view and
2. Click on View [¥ in the Views group on the N ve?rsa g

Home tab to toggle the view to Design mode
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WORKING WITH OTHER DATABASE OBJECTS

or in Data mode where data is parsed through the
object’s layout and presented to you. Once the

The key thing to remember with database objects
including tables is that, when open, they will

either be in Design mode where you can make
changes to the structure or layout of the object,

object is open it is an easy matter to toggle
between these two modes of operation.

£ qryCostsSummedByOwner o B O
Try This Yourself: T e -
Admin & Accounts General Equipment $3,744.00
. . . Adi & A it Office Furnit $1,212.00 L
,  Continue using the previous Wainienance | Gompuler Hardware % 97450 -
E 2 file with this exercise, or e N el e B
w i Maint Office Furnit $3,504.00
* gp?nbthe file Adgample lanagemeni | Offce Funitre 342550
ataoase.accadano... Product Computer Hardw $9,784.50
Froducton Goneral Equpment 5120000
Production Office Furniture $6,861.00
In the Navigation pane Sales Computer Hardware $18,804.00]
double CIle on ’ Sales General Equipment $11,849.00 =
Record: M lofld |k M % Mo Filter [ [Search
qryCostsSummedByOwner
to run the query and display o
the data parsed through it
o O? the Home tab Of the £ gryCostsSummedByOwner o B O
Ribbon, click on the top half - -
of View @ to display the ke =
design of the query o~
Qwne|™
e Click on Close | * to close o e
the query Field: | SR Asset Category Cost :
. Table: |Asset tems Asset ltems Asset Items =
o DOUble—C“Ck on Totak: | Group By Group By Sum
Sort:
rptAssetsGroupedByOwne hows
rs to run the report and 3
display it in preview mode e
o Click on Design View |%|in
the bottom right of the
. . . &l rptAssetsGroupe ners =
window, to display the design | (@) |mmeerme= = =%
structure of the report | # Report teaser
_ : jAssets Grouped By Owners |
Click on Close E to close T T T Tt
the report i Ererrn
: e | [ ] [omer | 5
1 ‘ " T ‘v“\: T fodel Ml 1T el o5
L | = L 1P Il; 1 s L
||| * Detail
] T Jpme ] | JWe [ ] e e Joe] |

# Owner Footer

- |||z Sumnary fof * & "emer =|' & " " fe [Ownds] & " (] & Conpt(*) &|" * & D Count(*)=L, "dftail sechrd","defail s
-1 ) -
o e e A
Emimed] T T T T [ [ [ [ [ [ [P
For Your Reference... Handy to Know...
To work with other database objects: e For forms and reports there is also a Layout
1. Double-click on the object name in the view. In Design view you see the name of
Navigation pane to run the object the controls used to display the data. You
. . \E i don’t actually see where the data ends up in
2. Cllc_k on View sl on the Ribbon to see the Design view. In Layout view you see the
design of the object data but can still make changes to the actual
layout of the form or report.
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CLOSING A DATABASE FILE

Closing a database file is a little different to
closing files in most other applications. In Access
2010 the data in a database file is saved as it is
being entered, while changes to structures and

Create and Use Databases - Microsoft Access 2010

designs are saved when the objects are closed.
You will never therefore be prompted to save a
database file because all of this has already been
done automatically.

Try This Yourself:

Continue using the
previous file with this
exercise, or open the file
A Sample
Database.accdb...

Same File

Click on the File tab of
the Ribbon to display
the Backstage View

Click on Close
Database to close the
database and return to
the New tab of
Backstage View

The New tab has been
selected because you
closed the database.
Only one database at a
time can be opened in
Access and Access
2010 will always display
the New tab of
Backstage View if a
database is not currently
open

(@9 -8s

Haome Create External Data

Database Tools

L.
A Sample Databas?.

Add-Ins

H Save

[';g Save Object As
Save Database As
ﬁ Open

[ Close Database

=

A Sample Database.... Publish to

Databasel.accdb
Database7.accdb

Databaseb.accdb

Relationships

| Access Services
L —

Information about A Sample Df
C:\Course Files for Access 2010%A Sample Database.a /

Share your database in
You can publish your Access af
your application from any sta

/‘\]\_/.

Define Relationships

Define how the data in tables
different tables that should m

&
@

A Sample Database....

Databasel.accdb

database

L —
Recent

[ [
Bl 9~ - s \
Home Create External Data Database Tools Add-Ins 8
= save /
Available Templates -
Bl save Object As /
(&) save Database As ¢ + fa} Home 8

5 Open H

J Close Database -

L
]

=

Blank web
database

Recent
templates

7
3

(2] Database7.accdb Office.com Templates 2
[2F] Database6.accdb - - - _‘F\)
[ [ [ [
Recent Assets Contacts Education Fin?
X
Print / / / ;
For Your Reference... Handy to Know...
To close a database: e The only time you'll be asked to save
1. Click on the File tab of the Ribbon anything in Access 2010 when closing a
. database, is if there is a Design view window
2. Click on Close Database
open and unsaved changes have been made
to the design prior to closing.
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EXITING FROM ACCESS 2010

You can exit from Access 2010 without the need
to worry about losing unsaved data. All of the
data in a database is saved as the data is
entered, while changes to the design of any

Create and Use Databases - Microsoft Access 2010

database objects are saved when the object is

closed.

C™ B R c R Microsoft Access
Try This Yourself: Home Create External Data Database Tools  Add-ns
s Available Templates
Before starting this B sove Object s . H"
exercise, ensure that 25““‘5‘””
Open

either an Access

£ Close Database

N
e

8

|

o

database is open, or that

A Sample Database...,

Backstage View is Blank web Recent Sample  Mytemplates  Newfrom
. Databasel accdb database templates templates existing
dlsplayed- 20 Database7 accdb Office.com Templates [search Office.com for templates e

Database6.accdb

If Backstage View is not i =, =
currently displayed, click f D g

on the File tab

Click on Exit to close
Access 2010 and return

o & o

Non-Profit

4

Finance

=4

Education

Recent Assets Inventory Issues &

Tasks
Print f :; ;_F ;

@
U
U
U

to the Windows deSktOp Share Personal Projects Sales & Samples Time &
Marketing Billing
Help

Add-Ins - ‘

For Your Reference... Handy to Know...

To exit from Access 2010: e You can exit from Access 2010 at any point

1. Click on the File tab of the Ribbon and at any stage. You don’t necessarily have
2. Click on Exit to be in Backstage View.
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MICROSOFT ACCESS ORIENTATION
Practice Exercise

Tasks: Completed:

Before starting this exercise you MUST have completed all of the
topics in the chapter Microsoft Access Orientation...

Start Access if it has not already been started, then open the database
file called PE_Access Orientation.accdb (it can be found in the same
folder as the student files)

Display a list of all Access objects in the database file

Open the table called Asset Items so you can see the data, then
display its structure

Close the table then open the Asset Inventory form in Design View
It should appear as shown in sample A on the following page...

Close the form then open the GST Paid By month report and display it
in Design View

It should appear as shown in sample B on the following page...

Close the database and then exit Access

Files required for PE_Access Orientation.accdb
exercise:

Files/work created by  None
student:

Exercise Completed:

© Watsonia Publishing Page 12 Access 2010 Orientation



